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R 101 continued Scripts

R - scripts
We do not want to start writing each model from scratch
every week.
We would like to save what we have done so far, and build
upon it next time.
R-scripts are simple text files that contain a list of R
commands. Basically they are computer programs.

1 Open New Script under the File menu.
2 This would create a blank window.

First, we need to name and save the script file.
3 Click on the blank script window.
4 Then choose Save as. . . from the File menu.
5 Go to the directory you wish to save the file in, or create

a new directory for your R-scripts and then choose it.
6 Once inside the directory, name the file hello.r and click

on the save button.
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R 101 continued Scripts

R - scripts

7 In the blank script window type print("Hello World!")

8 Now save the file using Save option form File menu or
pressing Ctrl + S.

9 Go back to the console / command window.

10 Type getwd() Enter
This gives you the current working directory of R.
You need change the working directory to the directory
which contains the hello.r file.

11 In the File menu choose Change dir.

12 Then change the directory to the one in which you
saved the hello.r file.

13 Verify that the working directory has changed by using
the getwd() command again.
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R 101 continued Scripts

R - scripts

14 To run the hello.r program type
source("hello.r") Enter

15 Another option is to choose the script window again
and choose Run all from the Edit menu.

16 A third option is to run only some selected text within the
script file or run only the line in which the cursor is
currently on.
This is achieved by selecting some text with the mouse
or moving the cursor to the line you want to run, and
then choosing "Run line or selection" from the Edit menu,
or just pressing Ctrl + R.

17 After you have run hello.r and observed the output in
the command / console window, close the hello.r script
window.
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R 101 continued Scripts

R - scripts
18 Create a new script and save it with the name

FirstPopModel.r
19 Write the following command lines into the script file:

1 Ninitial <- 10
2 lambda <- 2
3 N <- numeric(10)
4 Time <- 0:9
5 N[1] <- Ninitial
6 N[2] <- lambda * N[1]
7 N[3] <- lambda * N[2]
8 N[4] <- lambda * N[3]
9 . . . (i.e., repeat the previous style of commands, each

time incrementing the indexes)
10 N[10] <- lambda * N[9]
11 print(N)
12 plot( Time, N )

20 Save the new commands that you added to the script
file by pressing Ctrl + S
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R 101 continued Scripts

R - scripts

21 Now run the script file FirstPopModel.r
Make sure you are in the right directory by switching
back to the console window and using the getwd()
command and Change dir from File menu if needed.

22 Observe the output in the console window and the
graphical output.

23 Congratulations! You have now written and run your first
population growth model in R.
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R 101 continued Parameters

Parameters vs. Variables
The recursion relation for the discrete-time growth model we
just wrote is

Nt�1 � λ Nt
Obviously, N is the variable in this model

1 Its value changes over time.
2 We can attach a time index (1, 2, . . . , t, t� 1, etc.) to

each value .

The value of λ, however, is fixed – does not change over
time.

λ is a parameter in this model – it participates in
determining the dynamics of N , but its own value does
not change over time.
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R 101 continued Parameters

Parameters vs. Variables

Nt�1 � λ Nt

The value of λ may be different in different populations
or species or in different circumstances (different
climate, temperature, pH, nutrient level, etc.).
But for a single occurrence of the phenomenon
(population growth) it is fixed.
We can have as many parameters or variables as
needed.
For example, in the R-script we just wrote a second
parameter is Ninitial, the initial population size.
We usually write the parameters at the beginning of the
R-script file, so we can use them later and easily locate
and change their values.
Try to change the values of lambda and Ninitial and
observe how the output of the R program changes.
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R 101 continued Final word

Final word

A good programmer is a lazy programmer.

We wrote an R-script, so not to write the entire model
again and again each time we want to run it.

We defined the parameter lambda, so we won’t have to
go over and change all the lines that calculate N, each
time we want a different growth rate for the population.

During the course, we will learn additional ways to
make modeling in R easier, and the R-code more
compact, so we can do a lot with just few lines of code.
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Examples of unregulated population growth
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Examples of unregulated population growth

The trouble with tribbles
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Examples of unregulated population growth

Pests
Agricultural pests; e.g., aphids
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Examples of unregulated population growth

Pests

Stored-products pests
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Examples of unregulated population growth

Invasive species
Burmese python in Florida
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Examples of unregulated population growth

Invasive species

Brown tree snake in Guam
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Examples of unregulated population growth

Recovering populations

Elephants in Kruger national park, South Africa

OUTLINE ARITHTRIBBLE GEOMTRIBBLE ARITHPROBS GEOMPROBS SYNC1 SYNC2 SYNC3 10/ 19



Examples of unregulated population growth

Recovering populations

Baltic sea cormorants
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Examples of unregulated population growth

Recovering populations

European population following the Black Death epidemic of
14th century
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Examples of unregulated population growth

Diseases and epidemics
The AIDS epidemic
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Examples of unregulated population growth

Diseases and epidemics
The AIDS epidemic in Africa
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Examples of unregulated population growth

Human population growth

Global human population size
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Examples of unregulated population growth

Human population growth

Global human population size: projected based on
sustained unregulated growth
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Examples of unregulated population growth

Human population growth

Exponential economic growth
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Geometric growth model
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Geometric growth model

Arithmetic model of population growth
Population increases by a fixed amount each time-step.

. . .
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Geometric growth model

Arithmetic model of population growth

Why the arithmetic growth model is not a useful model?

1 Does not describe well the self-replicating nature of
organisms.

2 Positive population growth, even if initial population size
is zero – Spontaneous generation has been invalidated
long ago.

3 Same growth rate for both small and large populations.

4 If negative, eventually negative population size is
obtained – meaningless.

Arithmetic growth may apply when population grows mostly
by means of immigration.
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Geometric growth model

Geometric model of population growth
Population size is multiplied by a fixed factor time-step.

. . .
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Geometric growth model

Geometric model of population growth
Recursion relation/Difference equation of geometric growth

Nt�1 � λ Nt ô ∆N � pλ� 1qNt

λ is called finite rate of increase.

It is the average/mean per-capita multiplication factor
per one time-step.

Average in the sense that some individuals contribute
negative growth (die), some contribute positive growth
(reproduce), some contribute zero growth (survive but
do not reproduce). λ represents a weighted average of
these different contributions.

Classification of geometric growth:
λ ¡ 1 ñ ∆N ¡ 0, population grows.
λ � 1 ñ ∆N � 0, population size unchanged.
0 ¤ λ   1 ñ ∆N   0, population declines.
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Geometric growth model

Geometric model of population growth

Why the geometric growth model a more useful model than
arithmetic growth?

1 Directly related to the self-replicating nature of
organisms.

2 Nt � 0ñ ∆N � 0.

3 Larger populations grow more (have higher ∆N ; ∆N is
proportional to Nt).

4 Even if growth is negative (∆N   0; 0   λ   1), negative
values of population size are never obtained.
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Geometric growth model

The net reproductive rate, R0

A second important parameter is the net reproductive
rate, R0, which is the expected lifetime reproductive
output of a female.

Example: for unicellulars, when time between divisions
represents lifetime,

if there is no mortality, R0 � 2.
if there is 25% mortality between divisions,
R0 � 0.25 � 0� 0.75 � 2 � 1.5
if there is 50% mortality between divisions,
R0 � 0.5 � 0� 0.5 � 2 � 1
etc.

If we measure population growth in time-steps of 1
lifetime, λ � R0.

If in time-steps of 2 lifetimes, λ � R2
0.

If in time-steps of 3 lifetimes, λ � R3
0.
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Geometric growth model

The net reproductive rate, R0

Generalizing:
If T is lifetime / generation time,

and τ is the time-step of the model,
The relationship between λ and R0 is

λ � R
pτ{T q
0

So, for example, if we measure population growth in
time-steps of 10 generation times, τ � 10T , then λ � R10

0 .

But what about when τ   T we measure population
growth in time-steps shorter than lifetime / generation
time.

Does this general relation still apply?
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Geometric growth model

Synchronous and asynchronous reproduction

Synchronous reproduction: τ � T .
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Geometric growth model

Synchronous and asynchronous reproduction

Synchronous reproduction: τ � T {2.
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Geometric growth model

Synchronous and asynchronous reproduction

Synchronous reproduction: τ � T {4.
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Geometric growth model

Synchronous and asynchronous reproduction

But if we break the synchrony in reproduction.
For example, half the cells reproduce at noon and half at
midnight.
Asynchronous reproduction: τ � T .
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Geometric growth model

Synchronous and asynchronous reproduction

Asynchronous reproduction: τ � T {2.
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Geometric growth model

Synchronous and asynchronous reproduction

Asynchronous reproduction: τ � T {4.
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Geometric growth model

Synchronous and asynchronous reproduction

Even more asynchronous reproduction:
four "subpopulations", based on timing of division.
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Exponential growth model
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Exponential growth model

Exponential model of population growth

In the limit of completely asynchronous reproduction –
reproduction events are continuously distributed over time –
we obtain the exponential growth model.

The population growth trajectory is given by

Nptq � N0e
rt

The population growth rate is given by the differential
equation

dN{dt � rN

r is called instantaneous rate of increase.

r has units of 1/time – unlike λ and R0, which are pure
numbers.
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Exponential growth model

Exponential model of population growth

In the limit of completely asynchronous reproduction –
reproduction events are continuously distributed over time –
we obtain the exponential growth model.

The three parameters are related according to

r �
lnλ

τ
�

lnR0

T

Classification of geometric growth:
r ¡ 0 ñ dN{dt ¡ 0, population grows.
r � 0 ñ dN{dt � 0, population size unchanged.
r   0 ñ dN{dt   0, population declines.
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